»  Como  »  Software  »  Excel 
Un gramo de realizaciones vale más que una tonelada de promesas.
Mae West
Un buen jugador de hockey patina hacia donde está el disco, un gran jugador de hockey patina hacia donde el disco va a estar.
Wayne Gretzky
El que no tiene tiempo es que no tiene claro sus prioridades.
Didac Lee
En informática, sólo IBM es eterna: lo demás son empresas y productos efímeros.
caco3
Seguramente, si todos hablásemos esperanto no se habría producido ninguna guerra mundial.
Mazorca
Si eres bueno en algo, nunca lo hagas gratis.
El Joker en El Caballero Oscuro
Hijo, todo esto que ves que ahora es Google antes era campo.
Guillermo Saura
El hardware es un negocio muy difícil, sobre todo cuando el mercado lleva años maduro.
Eduardo Archanco
Napster es a las discográficas lo que Bitcon es a los bancos centrales.
malthus2012
Habremos avanzado como especie cuando los jóvenes nos pregunten: ¿Qué quería decir John Lennon con “Imagine”?.
Mazorca
Las particulas cuanticas son como yo, nunca puedes saber si estoy despierto o dormido hasta que me lo preguntas ... Y eso altera el resultado.
roader
Internet se ha convertido en algo demasiado importante como para dejarlo en manos de las empresas de telecomunicaciones.
Enrique Dans
Mientras las ovejas sean tontas, los pastores serán crueles.
pobrecito hablador
You Only Live Once.
Quien hace un cesto, hace ciento.
Refrán popular
La financiación es un acelerador de acontecimientos.
Mazorca
Yo antes era muy paranoico respecto a la privacidad. Ahora ya no me atrevo...
fht233
You are solving the wrong problem.
Paul MacCready
Make sure that you are on the right side.
Mazorca
Si no luchas, ya has perdido.
vonelvi
Como crear funciones con celdas variables gracias a INDIRECTO (Excel)
La función de Excel INDIRECTO la considero casi mágica. Es posible cambiar el texto de las celdas de cualquier otra función... ¡según el texto de otras celdas!. Parece un trabalenguas, pero INDIRECTO nos ofrece una gran versatilidad, evitando hacer uso de las temidas MACROS.

Para comprender esta función milagrosa vamos al turrón con un ejemplo muy sencillo. En la columna B tenemos una lista de números, y en la celda D7 sumamos del B1 al B3... “=SUMA(B1:B3)” dándonos como resultado la suma de esas tres celdas, usease 28. Hasta aquí nada nuevo.



Introducimos la función INDIRECTO, de forma que ahora sumamos desde la celda B1 hasta la... (lo que diga indirecto). Y ¿qué dice indirecto? INDIRECTO dice que el texto de la celda D3 será el valor de la fórmula. Como en la celda D3 pone el texto “B4” la función INDIRECTO se autotransforma con el contenido de la celda D3.

=SUMA(B1:INDIRECTO(D3))” es lo mismo que poner “=suma(B1:B4)





Bueno, este último ejemplo ya es para nota. Podemos jugar con esta maravillosa función para hacernos la vida más fácil.

Ahora queremos que nos sume la fila B desde la primera celda hasta la que nosotros deseemos pero... ¡¡¡escribiendo solo el NUMERO de la celda final!!!!

Lo conseguiremos con la siguiente fórmula: “=SUMA(B1:INDIRECTO("B"&D3))



Lo que sucede, es que sumamos desde B1 hasta INDIRECTO("B"&D3) o lo que es lo mismo hasta lo que ponga en la celda "B"&D3. Y ¿cuál es esa celda? pues el texto "B" más el texto de la celda D3, que forman el texto "B2".

Es muy entretenida esta función, y una vez comprendida ampliamos enormemente nuestro horizonte de posibilidades. Y como se suele decirse... el límite es vuestra imaginación.
Publicado por Mazorca    06.NOV.2014
Categoría: Excel

Añade tu comentario ...
Nombre
¿Cuanto suman 5 + 6?
enviar comentario
   
 
contacto 2019 © planifico.com